[CRIU] [PATCH 2/9] fd: Dynamically allocate args for the array of fds to drain

Pavel Emelyanov xemul at parallels.com
Fri Mar 1 13:01:55 EST 2013


On 03/01/2013 09:11 PM, Cyrill Gorcunov wrote:
> On Fri, Mar 01, 2013 at 08:02:34PM +0400, Pavel Emelyanov wrote:
>> --- a/include/parasite.h
>> +++ b/include/parasite.h
>> @@ -2,7 +2,7 @@
>>  #define __CR_PARASITE_H__
>>  
>>  #define PARASITE_STACK_SIZE	(16 << 10)
>> -#define PARASITE_ARG_SIZE_MIN	( 1 << 13)
>> +#define PARASITE_ARG_SIZE_MIN	( 1 << 12)
> 
> Hmm, I somehow missing, why you change this size again?

Because we no longer need such big args area. One page is enough.

> In previous patch it's set to 1 << 13, now to 1 << 12.

It was (strictly speaking) excessive change in previous patch.
I did it because I changed this line anyway and not 2^n value
was irritating to eyes :(

> (Also I think using shift which match to K/M/G is more
> easier to read, ie << 10/20/30 and such. Not a big deal
> though, could be cleaned up on top.

We need the PAGE_SHIFT macro, yes.

> .
> 




More information about the CRIU mailing list