[Devel] Re: [PATCH 1/16] Round up the API
xemul at openvz.org
Mon Jul 9 23:40:13 PDT 2007
Cedric Le Goater wrote:
> Pavel Emelianov wrote:
>> The set of functions process_session, task_session, process_group
>> and task_pgrp is confusing, as the names can be mixed with each other
>> when looking at the code for a long time.
>> The proposals are to
>> * equip the functions that return the integer with _nr suffix to
>> represent that fact,
>> * and to make all functions work with task (not process) by making
>> the common prefix of the same name.
>> For monotony the routines signal_session() and set_signal_session()
>> are replaced with task_session_nr() and set_task_session(), especially
>> since they are only used with the explicit task->signal dereference.
>> Signed-off-by: Pavel Emelianov <xemul at openvz.org>
>> Acked-by: Serge E. Hallyn <serue at us.ibm.com>
> please let's get that one in.
> I think we are all ok with it. right ?
Right. That's already the 3rd time I send it to Andrew...
Containers mailing list
Containers at lists.linux-foundation.org
More information about the Devel