[Devel] [PATCH RHEL8 COMMIT] mm: introduce kvmalloc_check() for safe calls to kvmalloc()

Konstantin Khorenko khorenko at virtuozzo.com
Wed Jun 2 13:26:01 MSK 2021


The commit is pushed to "branch-rh8-4.18.0-240.1.1.vz8.5.x-ovz" and will appear at https://src.openvz.org/scm/ovz/vzkernel.git
after rh8-4.18.0-240.1.1.vz8.5.34
------>
commit 9eefae0a7a5cec5af1e60f3bbb574bf1f81dffef
Author: Konstantin Khorenko <khorenko at virtuozzo.com>
Date:   Wed Jun 2 13:26:00 2021 +0300

    mm: introduce kvmalloc_check() for safe calls to kvmalloc()
    
    Sometimes a function which allocates high order pages is called with different
    flags while kvmalloc() should be called with at least GFP_KERNEL.
    
    kvmalloc_check() function uses kvmalloc() when possible depending on flags
    provided.
    
    https://jira.sw.ru/browse/PSBM-82593
    
    Signed-off-by: Konstantin Khorenko <khorenko at virtuozzo.com>
    Reviewed-by: Andrey Ryabinin <aryabinin at virtuozzo.com>
    
    [VvS RHEL77b rebase]
    
    (cherry picked from vz7 commit def125fece27 ("mm: introduce kvmalloc_check() for
    safe calls to kvmalloc()"))
    
    VZ 8 rebase part https://jira.sw.ru/browse/PSBM-127798
    
    Signed-off-by: Alexander Mikhalitsyn <alexander.mikhalitsyn at virtuozzo.com>
---
 include/linux/mm.h |  1 +
 mm/util.c          | 14 ++++++++++++++
 2 files changed, 15 insertions(+)

diff --git a/include/linux/mm.h b/include/linux/mm.h
index 807ecde29a42..1ae180a3f4a9 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -667,6 +667,7 @@ static inline void *kvcalloc(size_t n, size_t size, gfp_t flags)
 	return kvmalloc_array(n, size, flags | __GFP_ZERO);
 }
 
+extern void *kvmalloc_check(size_t size, gfp_t flags);
 extern void kvfree(const void *addr);
 
 static inline int compound_mapcount(struct page *page)
diff --git a/mm/util.c b/mm/util.c
index e99de9d3c8ae..b8b568fce0f9 100644
--- a/mm/util.c
+++ b/mm/util.c
@@ -502,6 +502,20 @@ void *kvmalloc_node(size_t size, gfp_t flags, int node)
 }
 EXPORT_SYMBOL(kvmalloc_node);
 
+/*
+ * Sometimes a function which allocates high order pages is called with
+ * different flags while kvmalloc() should be called with at least GFP_KERNEL.
+ * This function uses kvmalloc() when possible depending on flags provided.
+ */
+void *kvmalloc_check(size_t size, gfp_t flags)
+{
+	if ((flags & GFP_KERNEL) == GFP_KERNEL)
+		return kvmalloc(size, flags);
+	else
+		return kmalloc(size, flags);
+}
+EXPORT_SYMBOL(kvmalloc_check);
+
 void kvfree(const void *addr)
 {
 	if (is_vmalloc_addr(addr))


More information about the Devel mailing list