[Devel] [PATCH RH7 1/6] x86/asm: Use register variable to get stack pointer value

Kirill Tkhai ktkhai at virtuozzo.com
Fri May 22 20:02:51 MSK 2020


From: Andrey Ryabinin <aryabinin at virtuozzo.com>

ms commit 196bd485ee4f (part)

Currently we use current_stack_pointer() function to get the value
of the stack pointer register. Since commit:

f5caf621ee35 ("x86/asm: Fix inline asm call constraints for Clang")

... we have a stack register variable declared. It can be used instead of
current_stack_pointer() function which allows to optimize away some
excessive "mov %rsp, %<dst>" instructions:

  -mov    %rsp,%rdx
  -sub    %rdx,%rax
  -cmp    $0x3fff,%rax
  -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>

  +sub    %rsp,%rax
  +cmp    $0x3fff,%rax
  +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>

Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
and use it instead of the removed function.

Signed-off-by: Andrey Ryabinin <aryabinin at virtuozzo.com>
Reviewed-by: Josh Poimboeuf <jpoimboe at redhat.com>
Cc: Andy Lutomirski <luto at kernel.org>
Cc: Linus Torvalds <torvalds at linux-foundation.org>
Cc: Peter Zijlstra <peterz at infradead.org>
Cc: Thomas Gleixner <tglx at linutronix.de>
Link: http://lkml.kernel.org/r/20170929141537.29167-1-aryabinin@virtuozzo.com
Signed-off-by: Ingo Molnar <mingo at kernel.org>
Signed-off-by: Kirill Tkhai <ktkhai at virtuozzo.com>
---
 arch/x86/include/asm/asm.h |    5 +++++
 1 file changed, 5 insertions(+)

diff --git a/arch/x86/include/asm/asm.h b/arch/x86/include/asm/asm.h
index 41efcf174633..b15820cf90d2 100644
--- a/arch/x86/include/asm/asm.h
+++ b/arch/x86/include/asm/asm.h
@@ -83,4 +83,9 @@
 	" .popsection\n"
 #endif
 
+#ifndef __ASSEMBLY__
+register unsigned long current_stack_pointer asm(_ASM_SP);
+#define ASM_CALL_CONSTRAINT "+r" (current_stack_pointer)
+#endif
+
 #endif /* _ASM_X86_ASM_H */




More information about the Devel mailing list