[Devel] [PATCH rh7 1/3] memcg: rename memory.low_limit_in_bytes to memory.low
Vladimir Davydov
vdavydov at parallels.com
Mon May 25 07:05:46 PDT 2015
This is how it called upstream (in the unified hierarchy). Another
reason for rename is that memory.low is not actually a limit - it is a
low wss estimate.
Since memory.low was added not long before and it is only used by vcmmd
and we are haven't released Beta yet, such a rename seems to be
acceptable. In order not to break anything I'll make vcmmd work fine on
both kernels with memory.low and ones with memory.low_limit_in_bytes.
Signed-off-by: Vladimir Davydov <vdavydov at parallels.com>
---
mm/memcontrol.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index dd7f6ef19d76..0ca9cdff8c83 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -6117,7 +6117,7 @@ static struct cftype mem_cgroup_files[] = {
.read = mem_cgroup_read,
},
{
- .name = "low_limit_in_bytes",
+ .name = "low",
.write_string = mem_cgroup_low_write,
.read = mem_cgroup_low_read,
},
--
2.1.4
More information about the Devel
mailing list