[Devel] [PATCH 0/4] Proposed slab patches as basis for memcg

Glauber Costa glommer at parallels.com
Thu Jun 14 05:17:20 PDT 2012


Hi,

These four patches are sat in my tree for kmem memcg work.
All of them are preparation patches that touch the allocators
to make them more consistent, allowing me to later use them
from common code.

In this current form, they are supposed to be applied after
Cristoph's series. They are not, however, dependent on it.

Glauber Costa (4):
  slab: rename gfpflags to allocflags
  provide a common place for initcall processing in kmem_cache
  slab: move FULL state transition to an initcall
  make CFLGS_OFF_SLAB visible for all slabs

 include/linux/slab.h     |    2 ++
 include/linux/slab_def.h |    2 +-
 mm/slab.c                |   40 +++++++++++++++++++---------------------
 mm/slab.h                |    1 +
 mm/slab_common.c         |    5 +++++
 mm/slob.c                |    5 +++++
 mm/slub.c                |    4 +---
 7 files changed, 34 insertions(+), 25 deletions(-)

-- 
1.7.10.2




More information about the Devel mailing list