[Devel] Re: [PATCH 0/4] Proposed slab patches as basis for memcg
Pekka Enberg
penberg at kernel.org
Mon Jul 2 03:52:38 PDT 2012
On Thu, 14 Jun 2012, Glauber Costa wrote:
> These four patches are sat in my tree for kmem memcg work.
> All of them are preparation patches that touch the allocators
> to make them more consistent, allowing me to later use them
> from common code.
>
> In this current form, they are supposed to be applied after
> Cristoph's series. They are not, however, dependent on it.
>
> Glauber Costa (4):
> slab: rename gfpflags to allocflags
> provide a common place for initcall processing in kmem_cache
> slab: move FULL state transition to an initcall
> make CFLGS_OFF_SLAB visible for all slabs
>
> include/linux/slab.h | 2 ++
> include/linux/slab_def.h | 2 +-
> mm/slab.c | 40 +++++++++++++++++++---------------------
> mm/slab.h | 1 +
> mm/slab_common.c | 5 +++++
> mm/slob.c | 5 +++++
> mm/slub.c | 4 +---
> 7 files changed, 34 insertions(+), 25 deletions(-)
I applied the first patch. Rest of them don't apply on top of slab/next
branch because it's missing some of the key patches from Christoph's
series. Did anyone fix them up while I was offline?
Pekka
More information about the Devel
mailing list