[Devel] Re: [PATCH 1/9] [RFC] Support named cgroups hierarchies
Li Zefan
lizf at cn.fujitsu.com
Thu Jul 2 18:51:53 PDT 2009
>>> /*
>>> * A cgroupfs_root represents the root of a cgroup hierarchy,
>>> * and may be associated with a superblock to form an active
>>> @@ -93,6 +95,9 @@ struct cgroupfs_root {
>>>
>>> /* The path to use for release notifications. */
>>> char release_agent_path[PATH_MAX];
>>> +
>>> + /* The name for this hierarchy - may be empty */
>>> + char name[MAX_CGROUP_ROOT_NAMELEN];
>>> };
>>>
>> If you don't want to make cgroupfs_root bigger,
>>
>> cgroupfs_root {
>> ......
>> /* this must be the bottom of struct */
>> char name[0];
>> }
>>
>> Is a choice.
>
> I'd rather avoid something like that since I think it's less readable
> - I'd probably just make the name into a pointer in that case.
>
Whichever choice we make, the length should be limited I think.
>> BTW, reading a patch, any kind of charactors are allowed ?
>
> Yes, other than \000 of course. I guess maybe I should use
> seq_escape() to print the name to avoid confusion in the event that
> people put whitespace in there, or else just ban whitespace (or maybe
> all non-alphanumeric chars).
>
I don't think we need to care about this.
mount -t cgroup -o debug xxx /mnt
"xxx" can be any chars.
_______________________________________________
Containers mailing list
Containers at lists.linux-foundation.org
https://lists.linux-foundation.org/mailman/listinfo/containers
More information about the Devel
mailing list