[Devel] Re: [RFC v5][PATCH 2/8] General infrastructure for checkpoint restart
Dave Hansen
dave at linux.vnet.ibm.com
Mon Sep 15 10:54:20 PDT 2008
On Sat, 2008-09-13 at 19:06 -0400, Oren Laadan wrote:
>
> +int cr_read_obj_type(struct cr_ctx *ctx, void *buf, int n, int type)
> +{
> + struct cr_hdr h;
> + int ret;
> +
> + ret = cr_read_obj(ctx, &h, buf, n);
> + if (!ret) {
> + if (h.type == type)
> + ret = h.parent;
> + else
> + ret = -EINVAL;
> + }
> + return ret;
> +}
This one has been bugging me a bit. This adds one net line of code and
I think it's much easier to read:
{
struct cr_hdr h;
int ret;
ret = cr_read_obj(ctx, &h, buf, n);
if (ret)
return ret;
ret = -EINVAL;
if (h.type == type)
ret = h.parent;
return ret;
}
-- Dave
_______________________________________________
Containers mailing list
Containers at lists.linux-foundation.org
https://lists.linux-foundation.org/mailman/listinfo/containers
More information about the Devel
mailing list