[Devel] Re: [PATCH 2/2] ipc namespaces: implement support for posix msqueues
Serge E. Hallyn
serue at us.ibm.com
Thu Dec 18 13:36:33 PST 2008
Quoting Sukadev Bhattiprolu (sukadev at linux.vnet.ibm.com):
> | static int mqueue_get_sb(struct file_system_type *fs_type,
> | int flags, const char *dev_name,
> | void *data, struct vfsmount *mnt)
> | {
> | - return get_sb_single(fs_type, flags, data, mqueue_fill_super, mnt);
> | + if (flags & MS_KERNMOUNT)
> | + return get_sb_single_ns(fs_type, flags, data,
> | + mqueue_fill_super, mnt);
> | + return get_sb_single_ns(fs_type, flags, current->nsproxy->ipc_ns,
> | + mqueue_fill_super, mnt);
>
> nit. This maybe easier to read with an ns local variable and a single
> call to get_sb_single_ns().
The first time I read this I completely misunderstood what you
meant. Yes, that's nicer. Thanks for taking a look.
New version coming tomorrow (I want to stress this a bit).
thanks,
-serge
_______________________________________________
Containers mailing list
Containers at lists.linux-foundation.org
https://lists.linux-foundation.org/mailman/listinfo/containers
More information about the Devel
mailing list