[Devel] Re: [PATCH][ just for review] memory controller enhancements [4/5] statistics for memory cgroup
Balbir Singh
balbir at linux.vnet.ibm.com
Mon Oct 15 20:55:43 PDT 2007
KAMEZAWA Hiroyuki wrote:
> On Tue, 16 Oct 2007 07:38:23 +0900 (JST)
> yamamoto at valinux.co.jp (YAMAMOTO Takashi) wrote:
>
>>>>> +/*
>>>>> + * For batching....mem_cgroup_charge_statistics()(see below).
>>>>> + */
>>>>> +static inline void mem_cgroup_stat_add(struct mem_cgroup_stat *stat,
>>>>> + enum mem_cgroup_stat_index idx, int val)
>>>>> +{
>>>>> + int cpu = smp_processor_id();
>>>>> + stat->cpustat[cpu].count[idx] += val;
>>>>> +}
>>>> i think the function name should be something which implies batching.
>>>>
>>> Hm, How about this ?
>>> ==
>>> mem_cgroup_stat_add_atomic()
>>> ==
>>> and add this
>>> ==
>>> VM_BUG_ON(preempt_count() == 0)
>>> ==
>> _atomic sounds like a different thing to me. _nonpreemptible?
>>
> Hmm, ok.
>
> Thanks,
> -Kame
>
How about we call it __mem_cgroup_add_stat() and add a comment stating
that the routine should be called with pre-emption disabled?
We can also add the VM_BUG_ON() suggested.
--
Warm Regards,
Balbir Singh
Linux Technology Center
IBM, ISTL
_______________________________________________
Containers mailing list
Containers at lists.linux-foundation.org
https://lists.linux-foundation.org/mailman/listinfo/containers
More information about the Devel
mailing list