[Devel] Re: [-mm PATCH 2/8] Memory controller containers setup (v2)
Balbir Singh
balbir at linux.vnet.ibm.com
Fri Jul 6 14:07:19 PDT 2007
Dave Hansen wrote:
> On Thu, 2007-07-05 at 22:21 -0700, Balbir Singh wrote:
>> +struct mem_container {
>> + struct container_subsys_state css;
>> + /*
>> + * the counter to account for memory usage
>> + */
>> + struct res_counter res;
>> +};
>
> How about we call it "memory_usage"? That would kill two birds with one
> stone: get rid of the comment, and keep people from needing to refer to
> the comment to figure out what "res" *IS*.
>
Hmm.. res is the closest to resource counter. res_cnt is confusing.
res is a generic resource definition to indicate that we are dealing
with generic resource counters.
>> +/*
>> + * A meta page is associated with every page descriptor. The meta page
>> + * helps us identify information about the container
>> + */
>> +struct meta_page {
>> + struct list_head list; /* per container LRU list */
>> + struct page *page;
>> + struct mem_container *mem_container;
>> +};
>
> Why not just rename "list" to "lru_list" or "container_lru"?
>
I think just lru might be fine, meta_page->lru == container LRU.
>> +
>> +static inline struct mem_container *mem_container_from_cont(struct container
>> + *cnt)
>
> I'd probably break that line up differently:
>
> static inline
> struct mem_container *mem_container_from_cont(struct container *cnt)
>
Yes, that's better.
> BTW, do I see "cnt" meaning "container" now instead of "cnt"? ;)
>
Nope, I'll fix it to be cont
> Is somebody's favorite dog named "cnt" and you're just trying to remind
> yourself of them as often as possible?
>
It's an easy shorthands to use, like i or ref, num.
> -- Dave
>
--
Warm Regards,
Balbir Singh
Linux Technology Center
IBM, ISTL
_______________________________________________
Containers mailing list
Containers at lists.linux-foundation.org
https://lists.linux-foundation.org/mailman/listinfo/containers
More information about the Devel
mailing list