[Devel] [RFC][PATCH] Add child reaper to struct pspace

Eric W. Biederman ebiederm at xmission.com
Fri Sep 8 21:54:56 PDT 2006


Kirill Korotaev <dev at sw.ru> writes:

>> I guess we need to maintain a list of task_structs in the pspace and walk
>> that list. Will work on that as a separate patch.
> wait. we either need to have a list of _pids_ or it
> should be called task_namespace, not pid, since we are adding more 
> code related to tasks.

There will be a way to iterate through all of the pids.

It will probably be through a linked list of struct pid, but
it may be an in order traversal of some pid related data structure.

I was hoping for a moment I might be able to only implement one
struct pid, but I need some method to perform a reverse lookup
from struct pid to a (struct pid_namespace, pid_t) pair to
properly implement pid_nr().  A linked list of struct pid entries
is the obvious implementation.

Eric




More information about the Devel mailing list