[Devel] pspace name

Cedric Le Goater clg at fr.ibm.com
Thu Sep 7 06:22:30 PDT 2006


all,

'pspace' sounds wrong when you know about the other namespaces :

struct nsproxy {
	atomic_t count;
	spinlock_t nslock;
	struct uts_namespace *uts_ns;
	struct ipc_namespace *ipc_ns;
	struct user_namespace *user_ns;
	struct namespace *namespace;
};

'proc_namespace' might be confusing, what about 'task_namespace' ?

'namespace' should probably be renamed to something like 'mnt_namespace' ?

C.
_______________________________________________
Containers mailing list
Containers at lists.osdl.org
https://lists.osdl.org/mailman/listinfo/containers




More information about the Devel mailing list