[Devel] Re: [PATCH 1/6] IPC namespace core

James Morris jmorris at namei.org
Fri Jun 9 08:26:46 PDT 2006


On Fri, 9 Jun 2006, Kirill Korotaev wrote:

> This patch implements core IPC namespace changes:
> - ipc_namespace structure
> - new config option CONFIG_IPC_NS
> - adds CLONE_NEWIPC flag
> - unshare support
> 

Please post patches as inline text, so they can be reviewed inline.

+struct ipc_namespace {
+       struct kref     kref;
+       struct ipc_ids  *ids[3];
+
+       int             sem_ctls[4];

It'd be nice if these weren't magic numbers.



-- 
James Morris
<jmorris at namei.org>




More information about the Devel mailing list