[CRIU] [PATCH 1/3] usernsd: move MAX_MSG_SIZE to namespaces.h

Tycho Andersen tycho.andersen at canonical.com
Wed Sep 16 20:02:36 PDT 2015


We'll use this size in the next patch to avoid having to do some dynamic
allocation.

v2: call it MAX_UNSFD_MSG_SIZE instead
v3: fix all uses of MAX_MSG_SIZE :)

Signed-off-by: Tycho Andersen <tycho.andersen at canonical.com>
---
 include/namespaces.h | 2 ++
 namespaces.c         | 6 ++----
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/namespaces.h b/include/namespaces.h
index 52d2f34..18557af 100644
--- a/include/namespaces.h
+++ b/include/namespaces.h
@@ -95,6 +95,8 @@ typedef int (*uns_call_t)(void *arg, int fd);
  */
 #define UNS_FDOUT	0x2
 
+#define MAX_UNSFD_MSG_SIZE 256
+
 /*
  * When we're restoring inside user namespace, some things are
  * not allowed to be done there due to insufficient capabilities.
diff --git a/namespaces.c b/namespaces.c
index 9ce4783..76e05ce 100644
--- a/namespaces.c
+++ b/namespaces.c
@@ -849,8 +849,6 @@ struct unsc_msg {
 	char c[CMSG_SPACE(sizeof(int))];
 };
 
-#define MAX_MSG_SIZE	256
-
 static int usernsd_pid;
 
 static inline void unsc_msg_init(struct unsc_msg *m, uns_call_t *c,
@@ -910,7 +908,7 @@ static int usernsd(int sk)
 
 	while (1) {
 		struct unsc_msg um;
-		static char msg[MAX_MSG_SIZE];
+		static char msg[MAX_UNSFD_MSG_SIZE];
 		uns_call_t call;
 		int flags, fd, ret;
 
@@ -977,7 +975,7 @@ int userns_call(uns_call_t call, int flags,
 	bool async = flags & UNS_ASYNC;
 	struct unsc_msg um;
 
-	if (unlikely(arg_size > MAX_MSG_SIZE)) {
+	if (unlikely(arg_size > MAX_UNSFD_MSG_SIZE)) {
 		pr_err("UNS: message size exceeded\n");
 		return -1;
 	}
-- 
2.1.4



More information about the CRIU mailing list