[CRIU] [PATCH] mem: rename fill_pages into dump_pages

Andrey Vagin avagin at openvz.org
Thu Feb 13 03:59:21 PST 2014


This function splices data from a process to criu,
so dump_pages describes the real meaning.

Signed-off-by: Andrey Vagin <avagin at openvz.org>
---
 mem.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/mem.c b/mem.c
index 65a1b7a..8300f4e 100644
--- a/mem.c
+++ b/mem.c
@@ -189,7 +189,7 @@ static struct parasite_dump_pages_args *prep_dump_pages_args(struct parasite_ctl
 	return args;
 }
 
-static int fill_pages(struct page_pipe *pp, struct parasite_ctl *ctl,
+static int dump_pages(struct page_pipe *pp, struct parasite_ctl *ctl,
 			struct parasite_dump_pages_args *args, struct page_xfer *xfer)
 {
 	struct page_pipe_buf *ppb;
@@ -292,7 +292,7 @@ again:
 		if (ret == -EAGAIN) {
 			BUG_ON(pp_ret);
 
-			ret = fill_pages(pp, ctl, args, &xfer);
+			ret = dump_pages(pp, ctl, args, &xfer);
 			if (ret)
 				goto out_xfer;
 			page_pipe_reinit(pp);
@@ -302,7 +302,7 @@ again:
 			goto out_xfer;
 	}
 
-	ret = fill_pages(pp, ctl, args, pp_ret ? NULL : &xfer);
+	ret = dump_pages(pp, ctl, args, pp_ret ? NULL : &xfer);
 	if (ret)
 		goto out_xfer;
 
-- 
1.8.5.3



More information about the CRIU mailing list