[CRIU] [PATCH 10/37] criu: rename current_ns_mask to root_ns_mask

Pavel Emelyanov xemul at parallels.com
Fri Apr 18 08:16:06 PDT 2014


> @@ -179,10 +179,10 @@ static unsigned int generate_ns_id(int pid, unsigned int kid, struct ns_desc *nd
>  
>  	if (pid != getpid()) {
>  		if (pid == root_item->pid.real) {
> -			BUG_ON(current_ns_mask & nd->cflag);
> +			BUG_ON(root_ns_mask & nd->cflag);
>  			pr_info("Will take %s namespace in the image\n", nd->str);
> -			current_ns_mask |= nd->cflag;
> -		} else if (nd->cflag & ~CLONE_SUBNS) {
> +			root_ns_mask |= nd->cflag;
> +		} else if (nd->cflag != CLONE_NEWNS) {
>  			pr_err("Can't dump nested %s namespace for %d\n",
>  					nd->str, pid);
>  			return 0;

O_o


More information about the CRIU mailing list