[CRIU] Re: [PATCH 4/4] protobuf: Use RegFileEntry instead of
reg_file_entry structure v2
Pavel Emelyanov
xemul at parallels.com
Wed Jul 11 03:06:37 EDT 2012
On 07/07/2012 01:03 AM, Cyrill Gorcunov wrote:
>
> This patch switches reg_file_entry structure with RegFileEntry
> protobuf entry. Note that there a few nits remains
>
> - old fown_t structure doesn't scale well with FownEntry from
> RegFileEntry, so to not mess with rest of crtools code
> I've added a couple of opencoded copy operands, will clean
> this aspect up once rest of code is converted
>
> - the "show" procedure doesn't print fown for same reason
>
> v2:
> - rename fown_t to fown_entry in .proto
>
> Signed-off-by: Cyrill Gorcunov <gorcunov at openvz.org>
> ---
> cr-show.c | 28 ++++++----------------
> fifo.c | 4 ++-
> files-reg.c | 60 +++++++++++++++++++++++++++++------------------
> include/files-reg.h | 6 ++--
> include/image.h | 9 -------
> protobuf/Makefile | 2 +
> protobuf/fown.proto | 7 +++++
> protobuf/regfile.proto | 9 +++++++
> 8 files changed, 69 insertions(+), 56 deletions(-)
> create mode 100644 protobuf/fown.proto
> create mode 100644 protobuf/regfile.proto
>
> +import "fown.proto";
> +
> +message reg_file_entry {
> + required uint32 id = 1;
> + required uint32 flags = 2;
> + required uint64 pos = 3;
> + required fown_entry fown = 5;
> + required string name = 6;
> +}
Shouldn't the fown be optional?
More information about the CRIU
mailing list